Japanese Documents
Sonnet Tutorial

Introduction

この Tutorial では,SONNET製品の概要とそれらの併用方法について説明します.グラフィカルな project editorで回路を入力することから,Response Viewer,プロットツール,そして電流密度ビューアであなたのデータを見ることまで,簡単な例を通してあなたを案内します.この Tutorial では, project editorで考慮する必要がある設計上の問題についても説明します.

SONNETユーザーガイドには,SONNETのさまざまな機能に関する Tutorial や,各マニュアルのトランスレーターとインターフェイスの使用に関する Tutorial もあります.

この Tutorial は,SONNET Suite の概要を説明しながら,geometry project の作成方法と解析の実行方法を説明することを目的としています.以下のトピックについて説明します.

  • Sonnet Design Suiteの概要
  • ヘルプの使い方
  • Sonnet session window
  • project editorで回路geometry project を作成する
    • 新しい project を作成する
    • 単位
    • ボックスとセルのサイズ
    • ボックスカバー金属
    • 誘電体層
    • テクノロジー層
    • 回路を描く
  • Em,分析エンジン
  • Response Viewerにデータをプロットする.
  • 電流密度データの表示

SONNET Design Suite

SONNET解析ツールの Suite は以下の通りです.これらのツールを使用して,SONNETは他の多くの 設計レイアウトプログラムにオープンな環境を提供します.

*Optional Output Filesの詳細については,オプションの出力ファイルを参照してください.

SONNETは他のインターフェースやフォーマットからファイルをインポートする機能を提供します.それぞれのトランスレーターとインターフェースのための特定の Tutorial があります,しかし,あなたがあなたのすべての回路をインポートすることを計画しているとしても,SONNET環境に精通するためにこの Tutorial をすることを勧めます.

Help Resources

お客様は,以下の方法を使用してソフトウェアの実行に関する情報にアクセスすることができます.

  • SONNETのドキュメントは,任意のタブからHelp-SONNET Helpを選択することで利用できます.
  • 各タブのメインメニューからHelp-Help on this tabを選択すると,特定のタブタイプの情報を入手できます.
  • あなたは,ダイアログボックス内のHelpボタンをクリックすることによって,任意のSONNETダイアログボックスに関する情報を得ることができます.

ヒント:ヘルプビューアのツールバーのアイコンをクリックすると,現在表示されているヘルプページの目次からエントリを選択できます.

  • Windows:ダイアログボックス内の特定のコントロールに関するヘルプは,タイトルバーのをクリックしてください.そして情報が欲しいコントロールをクリックします.
  • LinuxおよびWindows:ダイアログボックス内の特定のコントロールに関するヘルプを表示するには,目的のコントロールを選択してからShift+F1を押します.
  • マニュアルは Welcome to Sonnet Suites またはマニュアルの目次から入手できます.

Session Window

SONNETソフトウェアを起動すると,セッションを開始します. SONNETセッションは,どのモジュール(タブ)が開いているか,そしてインターフェースタブがどのように設定されているかなど,現在実行中のSONNETソフトウェアを定義します.一度に実行できるセッションは1つだけですが,作成されるウィンドウとタブの数,および開かれる project の数に制限はありません.デフォルトのセッションタブを含む,すべてのタイプのSONNETタブに表示されるセッションマネージャは,現在のセッションで開いているすべてのタブと project を追跡することを可能にします.

セッション情報は自動的に保存され,次回SONNETを起動したときに使用されます.必要に応じて,セッションファイル(.sesn)を使用して手動でセッションを保存およびロードすることもできます. SONNETの起動時に最後のセッションを開きたくない場合は,セッションタブのEdit-Preferences...ダイアログボックスを参照してください.

セッションファイルには,次の情報が格納されています.

  • どのタブが開いていますか.
  • どの project が開いていてどのタブで開いているか
  • パネルとツールバーの配置を含むタブのウィンドウ構成.
  • セッションマネージャの内容

The Project Editor

project editorは,電磁界シミュレータemで解析したい回路に関して必要なすべての情報を指定できるグラフィカルインタフェースを提供します.

以下に示す回路例idig_fil5.sonは,直接タップ共振器を備えた5セクションのマイクロストリップインターディジタルバンドパスフィルタで,中心周波数は5GHzです.各共振器素子は中心周波数で約4分の1波長の長さであり,一端はビアでボックス底部カバー(アース)に接続している.

上の図では,基板を直接見下ろした上面からの2次元図です.これはproject editorタブに表示されるビューです.下の図は,[3D]タブに表示されているように, project editorでモデル化された6面金属ボックス内の回路の3次元図を示しています.

Creating a New Project

この Tutorial では,新しい空白の project から始めて,上記の回路例を入力します.geometry project には,ユーザがプロパティを入力するか,ファイルをSONNET環境に変換することによって提供されるgeometry 回路が含まれています.geometry project には,回路と内部部品のレイアウトと材料特性が含まれています.geometry project を解析すると,emは回路の電磁界シミュレーションを実行します.結果のシミュレーションデータはSONNET project に保存されます. SONNETセッションで開かれた project はセッションとは別に保存されることに注意してください.セッションは,開いている project へのポインタのみを格納します.

1._セッションタブのSONNETタスクバーにあるEdit Projectボタンをクリックし,表示されるポップアップメニューから New Geometryを選択してください.

新しい project が表示された状態で,新しいproject editorタブが開きます. project editorのインタフェースがproject editorタブに表示されます. project editorタブは,

アイコンで識別されます. project 名がタブに表示されます.これはまだ名前が付けられていない新しいgeometry なので,タブにはUntitledと表示されます. project editorタブがSONNETセッションウィンドウに追加されていることに注意してください.このウィンドウには,セッションタブとproject editorタブの2つのタブがあります.

2._project editorタブをクリックしてセッションウィンドウからドラッグします.

2番目のセッションウィンドウにproject editorタブが表示されます.元のセッションウィンドウにはセッションタブしか表示されません.一度に実行できるセッションは1つだけですが,複数のセッションウィンドウを開くことができます.各セッションウィンドウには,1つまたは複数のタブを含めることができます.タブを引き離して別のセッションウィンドウを作成したり,ツールバーやパネルをタブ内で移動させることができます. SONNETを終了すると設定の変更は自動的に保存されます.

3._作成したばかりの新しいウィンドウで,メインメニューからWindow-Dock Tabを選択します.

2つのタブが同じセッションウィンドウにもう一度表示されます. SONNETセッションの設定に関する詳細は,Reconfiguring Sonnet Windowsを参照してください.

Units

4._project editorの回路ツールバーのSettingsボタン

をクリックしてください

ディスプレイにCircuit Settingsダイアログボックスが表示されます.これは,ダイアログボックスのサイドバーメニューのエントリをクリックして選択する複数のページを含むグループダイアログボックスです.あなたの回路のためのセットアップの大部分はこのダイアログボックスで実行されるでしょう.またサイドバーメニューはセットアップを完了するためにされる必要があるタスクの「チェックリスト」として使われます.

5._まだ選択されていない場合は,サイドバーメニューのUnitsをクリックしてUnitsページを表示します.

Unitsページで,回路の測定単位を設定します.値を入力するときに単位を指定する必要はありません.ここで指定された単位は自動的に適用されます.これらは Tutorial に使用する単位なので,これ以上のアクションは必要ありません.

Box and Cell Size

SONNETのEM解析は,下図のように6面金属箱の中で行われます.この箱は箱の底面に平行な任意の数の誘電体層を含みます.金属ポリゴンは,誘電体層と誘電体層の界面のいずれかまたはすべてに配置することができ,ビアを使用してある層の金属ポリゴンを別の層に接続することができる.

箱の4つの側壁は無損失金属であり,正確で効率的な高周波EM解析にいくつかの利点があります.

  • 箱の壁は port のための完全な接地基準を提供します. 50または60dBを超える可能性があるダイナミックレンジのSパラメータデータが必要な場合は,適切なグランドリファレンスが非常に重要です.SONNETのサイドウォールグランドリファレンスを使用すると,日常的に100dBを超えるSパラメータダイナミックレンジを提供できます.
  • SONNETの基礎となる電磁界解析アルゴリズムではこのボックスの壁と一様なグリッドの元で,すべての回路構造の相互作用を厳密に計算できます.このアルゴリズムで使用される高速フーリエ変換(FFT)高速で,数値的に安定で,コンピュータ処理に非常に効率的にマッピングすることができます.
  • 高ダイナミックレンジの動作を厳密に期待される現実の回路は実際に金属箱の内側に実装されます.

この Tutorial の例では,2つの誘電体層を作成することによって,SONNETでマイクロストリップ回路をモデル化します.1つはあなたの基板を表し,もう1つは基板上の空気用です.マイクロストリップ用の金属ポリゴンは,これら2つの誘電体層の間の金属層に配置されています.ボックスの底部は,マイクロストリップ回路のグランドプレーンとして使用されています.ボックスの上部と下部には損失がある可能性があるため,グランドプレーンの損失をモデル化できます.

project editorで回路geometry を描画するだけでなく,ボックスと基板のパラメータを設定する必要があります.以下は,ボックスとセルサイズを設定するときに考慮する必要があるいくつかの要因についての説明です.

基板はボックスの底面を覆うので,ボックスのパラメータを指定することによって基板の寸法が定義されまる.Cell sizeBox(ボックスサイズ),Num.cells(セル数)の3つの相互に関連するパラメータがあります.それらの関係は次のとおりです.

Num.cells * Cell size = Box

したがって,あるパラメータを変更すると,自動的に別のパラメータが変更される可能性があります.値をロックすることによってサイズを変更するときは,いずれのパラメータも一定に保つことができます.

Cellは解析の最小単位であり,電磁界解析では自動的にCellをよりおおきなサブセクションにまとめます.サブセクションの大きさは必要に応じて変化します. サブセクションを小さくするほど,結果はより正確になり,結果を取得するのにかかる時間も長くなります.したがって,Cell sizeを選択する際に考慮すべき精度と処理時間の間にはトレードオフがあります. project editorでは,サブセクションのサイズを制御できます.サブセクション化の詳細については,SONNET User's GuideのSubsectioningを参照してください.

Cell sizeはキリのよい数値である必要はありません.たとえば,9.5ミル幅の線を分析する場合は,Cell sizeを0.5ミルに設定する必要はありません. 4.75ミル(9.5ミルを2で割る)または3.16667ミル(9.5ミルを3で割る)に設定することができます.使用するサブセクションが少なくなるため,これにより分析が高速化されます.また,セルの幅は長さと同じである必要はありません. project editorに等間隔のドットで構成されたグリッドが表示されることに注意してください.各格子点間の距離はCell sizeです. Cell sizeは直接入力することも,Num.cellsを入力することもできます.これにより,基板面あたりのNum.cellsが設定されるため,Boxサイズに関連してCell sizeが暗黙的に指定されます.Num.cellsは整数でなければならないことに注意してください.

訳注:Sonnetを初めて使う方の殆どがCell sizeを製造上の精度と同程度の小さな値に,Num.cellsを異常に大きな値に設定し,現実的でない解析時間やメモリ使用量に絶望してしまいます.解析時間への影響は,自動的に生成されるサブセクションの大きさよりも,Num.cellsに強く依存します.Cell sizeはそれぞれの回路で可能な限り大きく設定してください.Cell sizeが精度を著しく損なうほどに大きい場合はSonnetは自動的に警告を出します.

6._Circuit SettingsダイアログボックスのサイドバーメニューのBoxをクリックします.

Boxページが表示されます.まだ選択されていない場合は,BoxページのBoxタブをクリックしてください.この回路では,ボックスサイズを380ミルx 280ミルに設定します.

7._Circuit SettingsダイアログボックスのBoxページのBox行にあるXテキスト入力ボックスに380と入力します.

8._Circuit SettingsダイアログボックスのBoxページのBox行にあるYテキスト入力ボックスに280と入力します.

これらの値を入力すると,セル数の値が新しいボックスサイズに対応するように更新されます.

回路の寸法を観察すると,x方向とy方向の両方向における寸法の最大公約数は2ミルであることが分かります.フィルタのフィードラインの幅は16ミル,共振器の幅は20ミル,共振器とフィードラインの長さはすべて偶数のミルです.全てのメタライゼーションがセルグリッド上にくるようにするために,2×2ミルのセルサイズが使用されます.メタライゼーションをグリッドに載せない方法も可能ですが,ここでは使いません.2ミル×2ミルのセルサイズは,最小の処理時間を必要としながらこの回路に十分な精度を提供する.

9._Circuit SettingsダイアログボックスのBoxページのCell Size行にあるXテキスト入力ボックスに2と入力します.

10._Circuit SettingsダイアログボックスのBoxページのCell Size行にあるYテキスト入力ボックスに2と入力します.

Num.Cellsに注意してください.Num.Cellsエントリも更新されます.

Box Cover Metals

回路内の金属は,プレーナとビアの2種類の金属タイプを使用してモデル化されています.プレーナ金属タイプは,金属ポリゴンとボックスカバーに使用されます(BOXの側壁は常に無損失金属を使用してモデル化されます).ビア金属タイプは,ビアポリゴンをモデル化するために使用されます.

金属タイプを定義してから,それらをポリゴンまたはボックスカバーに割り当てることで,ボックスカバーまたはポリゴンで使用する金属の種類を定義します.

各層に複数の種類の金属を使うことができますし, project に定義できる金属の種類の数に制限はありません.金属の損失をモデル化するには,金属の種類を定義するときに金属の損失特性を入力します.提供されている金属タイプのライブラリを使用したり,複数の project で使用する独自の金属ライブラリを定義することもできます.

この Tutorial では,金属ライブラリで定義されているゴールド金属タイプを使用して,ボックスの上部カバーとボックスの下部カバー(グランドプレーン)をモデル化します.

通常,金属タイプはCircuit SettingsダイアログボックスのMetals/Bricksページを使用して定義されますが,Boxページはカバー金属に割り当てる金属タイプを定義する方法も提供します.

11._BoxページのTop Metalの下にあるNew...ボタンをクリックします.

Metal Editorダイアログボックスが表示されます.Metal Editorダイアログボックスでは,新しい金属の種類を定義できます.

12._Metal EditorダイアログボックスのSelect from Libraryボタンをクリックします.

金属の種類を定義する方法は2つあります.金属モデルを選択してパラメータを入力するか,金属ライブラリから金属定義を選択することができます.この Tutorial では,ライブラリの金属タイプを使います.

訳注:最近の微小な回路やミリ波回路や印刷工法など新しい導体生成プロセスでは既知の理論とパラメータから解析されるよりずっと大きな導体損失になる場合があります.予め定義された金属のパラメータだけで得られる解析結果の精度が不十分な可能性を忘れないでください.

Select from Libraryボタンをクリックすると,Libraryダイアログボックスがディスプレイに表示されます.

13._Libraryダイアログボックスの金属のリストでGoldエントリをクリックします.

Libraryダイアログボックスに,SONNETのインストール時に提供されているデフォルトのグローバルライブラリが表示されます.あなたはあなた自身の使用のためにローカルライブラリを定義することも,グローバルライブラリに金属タイプを追加することもできます.詳細については,LibraryダイアログボックスのHelpボタンをクリックしてください.

選択すると,Goldエントリが強調表示されます.エントリに金属タイプのパラメータが表示されます.

14._OKボタンをクリックしてダイアログボックスを閉じ,金属定義を適用します.

Metal Editorダイアログボックスの設定は,ライブラリ内のGoldに対して定義されているパラメータで更新されます.

15._Metal EditorダイアログボックスのNameテキスト入力ボックスにCoverと入力します.

Nameエントリのすぐ右側にPatternエントリがあります.新しいパターンはソフトウェアによって自動的に割り当てられています.あなたがそうしたいならば,あなたは金属のために別のパターンを選ぶために上下の矢印を使うことができます.この Tutorial では,デフォルトの割り当てパターンを使用します.金属パターンは,金属タイプが定義されている回路内の任意のポリゴンの金属フィルに使用され,金属タイプを視覚的に識別しやすくします.

16._Thicknessテキスト入力ボックスに0.1と入力します.

ここで使用されている標準金属タイプモデルは,厚さゼロモデルとして定義されています.金属の厚さは損失の計算にのみ使用されます.それはあなたの回路のメタライゼーションの物理的な厚さを変えません.

17._Metal EditorダイアログボックスのCurrent Ratioテキスト入力ボックスに「0.0」を入力します.

電流比は,厚さが表皮深さよりはるかに大きい非常に高い周波数で,金属の上面を流れる電流と金属の下面を流れる電流との比として定義されます. 高周波ではCoverの金属が表皮深さよりずっと厚く, ほとんどの電流が金属の片面だけに流れるため,CoverCurrent Ratio0です.

18._Metal EditorダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じ,変更を適用します.

金属タイプ Coverが作成され,Top metalに適用されます. Circuit SettingsダイアログボックスのBoxページが更新され,Top metalドロップリストにCoverが表示されます.

19._Bottom metalドロップリストからCoverを選択します.

Bottom metalドロップリストが更新され,Coverが表示されます.これは,作成したばかりのCover金属タイプをボックスのBottom metalに適用します. Boxページは,下の図のように表示されます.

20._Circuit SettingsダイアログボックスのApplyボタンをクリックします.

これにより,今行った変更が保存されます.

Dielectric Layers

すべてのSONNET geometry project は2つ以上の誘電体層で構成されています. SONNET geometry project の誘電体層の数に制限はありませんが,各層は単一の誘電体材料で構成されている必要があります.金属ポリゴンは,2つの誘電体層の間の界面に配置され,通常は厚さゼロとしてモデル化されますが,SONNETの厚い金属モデルThick Metal Modelを使用してモデル化することもできます.ビアは,ある層の金属ポリゴンを別の層の金属に接続するためにも使用できます.

以下に示す Circuit SettingダイアログボックスのDielectrics Layersページ,または project editorタブの左端のStackup Managerを使用して,回路に誘電体を追加したり,回路内の誘電体を編集したりできます.新しい誘電体層が追加されるたびに,対応する金属層も新しい誘電体層の下部に追加されます.

この例は,回路の3次元図を示しています(z軸を誇張しています).描かれた回路は現実的ではなく,箱のセットアップを説明する目的のためだけに使われることに注意してください.右側は,project editorタブの左端のStackup Managerが示す回路の「側面」ビュー, 表はCircuit SettingダイアログボックスのDielectrics Layersページの例です.

21._Circuit Settingsダイアログボックスのサイドバーメニューの「Dielectric Layers」をクリックします.

Circuit Settingsダイアログボックスが更新されてDielectric Layersページが表示され,ここでボックス内の回路のおおよその「側面」が表に示され,誘電体層を指定できます.また,project editorタブの左端のStackup Managerにスタックアップが表示されることもあります. project editorの「層」番号が左側に表示されます.

訳注:SONNETにおける「層」とは誘電体層とその誘電体層の底面に配置された導体層の両方を含みます.基板CADでの導体層とは異なることに注意してください.

 22._Circuit SettingsダイアログボックスのDielectric LayersページでSubstrate誘電体層をクリックします.

これにより誘電体層が選択される.

23.誘電体層リストの上にあるEditボタンをクリックします.

Dielectric Editorダイアログボックスが開きます.このダイアログボックスでは,誘電体層の厚さなどのパラメータを編集できます.

24._Dielectric EditorダイアログボックスのSelect Dielectric from Libraryボタンをクリックします.

ディスプレイにLibraryダイアログボックスが表示されます.必要なら誘電率パラメータを直接編集してMy Libraryを定義することができますが,この例ではデフォルトのGlobal Libraryから誘電体材料を選択しましょう.

25._LibraryダイアログボックスのAlumina(96%)エントリをクリックして選択します.

26._LibraryダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じ,変更を適用します.

Dielectric EditorダイアログボックスがAlumina(96%)のパラメータで更新されます.

27._Dielectric EditorダイアログボックスのThicknessテキスト入力ボックスに「15」と入力します.この例では基板の厚さは15ミルです.

28._Dielectric EditorダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じ,変更を適用します.

Circuit SettingsダイアログボックスのDielectric Layersページの下部の誘電体層のパラメータが新しいパラメータで更新されます.

29._Dielectric Layersページの一番上の誘電体層のThicknessエントリーをクリックします.

フィールドを選択すると,編集モードになります.この誘電体層は既にAirと定義されており,この例の回路の上は空気なので,厚さ以外のパラメータを変更する必要はありません.これはDielectric Layersページで直接編集できます. (たとえBoxページでTop MetalFree Spaceに設定されている場合でも)空気層は回路をカバーから遠ざけるための厚さが必要です.一番上の誘電体層は,基板の厚さの少なくとも3〜5倍でなければなりません.

訳注:このAir層の厚さはたとえ実際の回路がシールドケースに入っていない場合でも,実験室の天井の高さ2mに設定してはいけません.

訳注:アンテナの解析ではこのAir層の厚さはSonnetによるアンテナ解析のガイドラインに従ってください.

30._Dielectric LayersページのThickness入力ボックスに150と入力します.

空気層は150ミルの厚さに設定されています. Circuit SettingsダイアログボックスのDielectric Layersページが更新され,次の図のように表示されます.

31._Circuit SettingsダイアログボックスのApplyボタンをクリックして,変更内容を保存します.

これで誘電体層の設定は完了です.

Technology Layers

テクノロジレイヤを使用すると,SONNET project で配置されている金属層など,共通のプロパティを持つオブジェクトのグループを定義できます.これにより,回路内の多数のオブジェクトをより簡単に制御し,それらのオブジェクトにできるだけ効率的に変更を加えることができます.

この例の回路のすべての金属ポリゴンは同じ金属で,すべてのビアも同じ金属タイプなので,それらを管理するためのテクノロジレイヤを作成します. テクノロジレイヤを作成する2つの異なる方法が示されます.Circuit Settingsダイアログボックスを使用する方法とStackup Managerを使用する方法です.

テクノロジレイヤはオプションです.テクノロジレイヤを作成する場合は, project 内の層に割り当てる必要がありますが,すべての層に割り当てたり, project にテクノロジレイヤを含めたりする必要はありません.

32._Circuit SettingsダイアログボックスのサイドバーメニューのTech Layersをクリックします.

[Circuit Settings]ダイアログボックスの外観が更新され,Technology Layersページが表示されます.デフォルトのMetal Technology LayerであるMetal1がリストに表示されます.

33._Metal1エントリをクリックして選択し,次に編集ボタンをクリックします

. 

Technology Layer Editorダイアログボックスがディスプレイに表示されます.このダイアログボックスでは,テクノロジレイヤのパラメータを入力または編集できます.

34._Technology Layer EditorダイアログボックスのNameテキスト入力ボックスにTraceと入力します.

これは,Stackup Managerに表示されるテクノロジレイヤの名前です.

35._Technology Layer EditorダイアログボックスのPlanar MetalセクションにあるNew...ボタンをクリックします.

Metal Editorダイアログボックスが表示されます.Metal Technology Layerに使用する新しい金属タイプを定義します.

36._NameGold_TraceConductivity4.09e7Thickness0.1と入力します.解析に使用する導体モデルModelNormalとします.

37._Metal EditorダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じます.

Technology Layer Editorダイアログボックスが更新され,このテクノロジレイヤTraceに使用されるPlanar Metalタイプとして Gold_Traceが表示されます.他に変更を加える必要はありません.

38._Technology Layer EditorダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じ,変更を適用します.

Circuit SettingsダイアログボックスのTechnology Layersページが更新され,Trace テクノロジレイヤが表示されるようになりました.

39._Circuit SettingsダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じ,変更内容を適用します.

project editorタブが更新され,新しい素材サイズが表示され,project editorタブの左端のStackup ManagerTraceテクノロジレイヤが表示されます.基板誘電体層もまた,Alumina(96%)と表示されます.Stackup Managerは縮尺通りではありません.すべての誘電体層は同じ厚さで表示されます.

40._Stackup ManagerAlumina(96%)誘電体層を右クリックして表示されるポップアップメニューからAdd Via Tech Layer...を選択します.

Technology Layer Editorダイアログボックスがディスプレイに表示されます.今回のTypeVia Technology Layerです.下の誘電体をクリックしたので,From levelGND,To level0になりました.これは基板表面から裏面のGNDへのVIAを意味します.

41._Technology Layer EditorダイアログボックスのNameテキスト入力ボックスにVia_Gndと入力します.

これは,Stackup Managerに表示されるテクノロジレイヤの名前です.前述のように,From levelTo levelはすでに正しく設定されています.

42._Technology Layer EditorダイアログボックスのVia MetalセクションにあるNewボタンをクリックします.

ディスプレイにMetal Editorダイアログボックスが表示されます.Via Technology Layerに使用する新しい金属タイプを定義します.この金属タイプはデフォルトの体積損失モデルを使用します.

43._NameGold_ViaConductivity4.09e7Wall thickness0.1を入力します.解析に使用する導体モデルModelVolumeとします.

この金属タイプは,Volume PropertiesWall thicknessを使用します.このモデルでは,壁の厚さと各ビアポリゴンの形状を使用して,損失計算のための断面積が決定されます.

44._OKボタンをクリックしてMetal Editorダイアログボックスを閉じ,変更を適用します.

Technology Layer Editorダイアログボックスが更新され,このテクノロジレイヤVia_Gndに使用されるVia Metalタイプとして Gold_Viaが表示されます.他に変更を加える必要はありません.

45._Technology Layer EditorダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じます.

project editorタブの左端のStackup Managerが更新され,Via_Gndテクノロジレイヤが表示されます.Via_GndテクノロジレイヤがGNDから層0まで描かれていることに注意してください.Via Technology LayerFrom levelTo levelの定義に違いはありません.From level0を,To levelGNDを指定しても同じ結果になります.

これで回線の設定は完了です.次のセクションでは,回路を描きます.

Drawing the Circuit

このセクションでは, project editorのさまざまなツールを使って回路を入力する方法を説明します.この層0で作成されたすべての金属ポリゴンには,自動的にTrace テクノロジレイヤが割り当てられます.

現在Stackup Managerで下部誘電体層が選択されています.メインウィンドウの金属層の表示は,常にStackup Managerで選択した誘電体の下の金属層です.したがって,現在の表示はボックス下部(GND)です.

46._Stackup Managerで上の誘電体層をクリックして,Level 0の表示に変更します.

ツールバーから表示層を変更することもできます.デフォルトのproject editorタブでは,表示スペースの制限によりツールバーに右側が表示されていないかもしれません.>>をクリックしてツールバー全体を表示します.現在の層番号0が表示されていることを確認してください.

Adding a Polygon

47._project editorのステータスバーにあるLocal Originアイコン

をクリックしてください. 

ステータスバーはproject editorタブの下部にあります. Local Originダイアログボックスが表示されます.

48._X70Y26と入力して,原点を70,26に設定します.

この位置は,最初に描くポリゴンの角です.

49._Local OriginダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じ,変更を適用します.

回路図が更新され,原点記号が70,26に移動します.

50._Insertツールバーの四角形アイコン

をクリックします.

訳注:メニューから[Insert]-[Draw Rectangle]を選ぶか,キーボードでRキーを押しても四角形の追加モードになります.

カーソルの外観が変わり,Add Rectangleモードになり,Add Rectangleツールバーが表示されます.テクノロジレイヤが定義されているので,Add RectangleツールバーはデフォルトでTraceテクノロジレイヤに割り当てられた金属ポリゴンを追加します.テクノロジレイヤが選択されているため,金属タイプドロップリストは無効になっています.

51.回路図のLocal Originシンボルの上にカーソルを移動して,シンボルが青い円で強調表示されたら,クリックします.

project editorタブ下部のステータスバーの左端に表示される座標値は0,0と表示されます.これはあなたの長方形の最初の点です.

訳注:単にキーボードから 0,0[Enter]と入力しても,原点にカーソルを移動できます.

52.キーボードで20,224[Enter]と入力し,Enterキーを押します.

20,224[Enter]を入力すると,値がステータスバーのXエントリとYエントリに表示されます. Enterキーを押すと入力が完了し,最初の共振子が回路図に追加されます.キーボードを使って値を入力するとき,間違えた場合はバックスペースキーを使うことができます.

Adding a Via

この回路例では共振器をグランドに接続します.グランド接続をモデル化するには,金属層間でz方向に電流を流すことを可能にする特別な種類のサブセクション,つまりビアが必要です.

SONNETビアは,回路内の任意の層の金属を他の任意の層の金属に接続するために使用できます.これらは一般に,グランドへのビア,エアブリッジへの接続をモデル化するために使用され,さらにワイヤボンドを近似するためにも使用できます.

SONNETビアはその高さに沿って均一な電流分布を使用するため,電気的に長い垂直構造をモデル化するために使用することを意図していません.したがって,ビアの高さは波長のごく一部にする必要があります.

53._Stackup Managerで,Via_Gndをクリックします.

GND層の表示に変わります.今描いた共振器は破線の輪郭で表されます.回路内の他の金属層にある金属ポリゴンはすべてこのように破線で表示されます. なるように, ビアテクノロジレイヤを選択したのでビアポリゴンを追加したときにデフォルトでVia_Gndになります.

54._マウスの中ボタンをクリックしてからズームインしたい領域を囲むようにドラッグして,レゾネータの下部をズームインします.

ビューツールバーのZoomボタンを使用することもできます.マウスの中央ボタンをダブルクリックすると,全画面表示に戻ります.ズーム表示を表示するために回路図が再描画されます.下の図のように見えるはずです.

訳注:キーボードのスペースバーを押してもZoomになります.拡大しすぎたときはキーボードの[ctrl]Fを押せば全体表示に戻ります.マウスホイールを回す方向でも拡大縮小できます.

55._project editorタブのメニューからInsert@-Via-Circular Via`を選択します.

ディスプレイにCircle Propertiesダイアログボックスが表示されます.

56._Diameter10を入力します.

他の値は適切なので,これ以上変更する必要はありません.

57._OKボタンをクリックしてダイアログボックスを閉じ,変更を適用します.

ダイアログボックスを閉じると,円形のビアの輪郭が,ビアの中心を示す青い十字付きで表示されます. X両端揃えとY両端揃えは両方とも「中央揃え」に設定されているので,ビアの中央はマウスをクリックした場所に配置されます.

58._ステータスバーの表示が10,10になるまでカーソルを動かし,次にマウスをクリックします.

これらの値は,私たちの共振器の角にあるローカル原点を基準にしています.これにより,ビアが共振器内に配置されます.ビアがビューに追加されます.指定したビアを表すアウトラインがありますが,emで解析された実際の金属を示す金属フィルは,太い緑色の長方形です.デフォルトでは,SONNETは新しいビアポリゴンにリングメッシュ塗りつぶしを使用します.これは,ビアポリゴンの周囲全体に沿ってビアサブセクションを中空の中心で配置します.この周囲は常に1セル幅です.ビアポリゴンがサーキットに追加されたら,他の種類のメッシュ塗りつぶしを割り当てることができます.この例では,デフォルトのリングメッシュ塗りつぶしが使用されています.

59._1つ上の層に進むと金属層0が表示されます.

これを行うには,Stackup Managerの一番上の誘電体層をクリックするか,LevelツールバーのUpボタンをクリックするか,上矢印キーを使用します.表示がビアの上部に変わります.このビアは自動的にビアテクノロジレイヤのVia_Gndに割り当てられ,GND層と層0を接続します.GND層のビア矢印は上を向いていますが,層0のビア矢印は下を向いて接続先の層を示しています.

60._ViewツールバーのFull Viewボタン

をクリックしてください.

フルサーキットビューが表示されます.前述したように,マウスの中央ボタンをダブルクリックして全画面表示に戻ることもできます.

61._マウスをクリックしてドラッグし,レゾネータとビアを選択します.

共振器とビアは強調表示されています.

62._project editorのメインメニューから[Object]-[Move...]を選択します.

ディスプレイにMoveダイアログボックスが表示されます.

63._[コピーを作成]チェックボックスをオンにします.

64._X delta50,Y delta0を入力します.

65._Applyボタンをクリックして共振器をコピーし,50ミル移動します.

2つ目の共振器とビアのペアがあなたの回路図に追加され,その新しい共振器が選択されています.

66._X deltaテキスト入力ボックスに60入力して,Applyボタンをクリックします.

第2の共振器から60ミル離れたところに第3の共振器が作られます.

67._もう一度Applyボタンをクリックします.

4番目の共振器は,3番目の共振器から60ミル離れたところに作成されます.

68._X deltaテキスト入力ボックスに50と入力し,OKをクリックします.

5番目の共振器は4番目の共振器から50ミル離れたところに作られます.これが追加したい最後の共振子なので,5番目の共振子を作成すのにApplyでなくOKボタンをクリックしました.回路は下の絵のように見えるはずです.

次に,最初と最後の共振器の高さを4ミル(2セル)増やす必要があります.

69._ズームボタンをクリックして,最初のレゾネータの上部をズームインします

共振器の上部のグリッドを示す点を見ることができるように拡大してください.

70._共振器をクリックして選択します.

共振器を選択すると,四角形と円の形の編集ハンドルが表示されます.これらのコントロールを使用すると,ポリゴンをすばやく直感的に変更できます.

71._編集ハンドル(上端の中央にある四角形)をクリックし,2つのセル(グリッド上の2つの目盛り)になるまで上にドラッグします.

編集ハンドルをドラッグすると,下に示すように,ステータスバーにデルタ表示が表示されます.これにより,ハンドルを4ミル移動させることができます.

72._同様にして,最後の共振器の高さを延ばす.

次に,2番目と4番目の共振器のビアを移動します.

73._フルビューに移動し,2番目の共振子のビアをクリックして選択します.

74._[Shift]キーを押しながら4番目のレゾネータのビアをクリックして選択します.

[Shift]キーを押したままにすると,複数のオブジェクトを次々に選択抱きます. 2番目と4番目の共振器のビアがハイライトされているはずです.

75._キーボードで@ 0,204[Enter]と入力します.

両方のビアはY方向に204ミル移動し,共振器の上部近くにあります.キーボードで@を使用すると,相対座標の指定ができます.以前と同様に,エントリはステータスバーに表示されます.相対移動キーボードコマンドは,ポリゴンの移動,ポイントの移動,ポリゴンの追加,四角形の追加など,さまざまな編集操作に使用できます.詳細については,ポイントとポリゴンのキーボード入力を参照してください.

回路は以下のようになります.

次に,フィルタの両端にタップラインを追加します.長方形のポリゴンを作成し,次にテーパーのポリゴンを作成し,2つのポリゴンを結合してタップラインを作成します.

76._project editorのステータスバーにあるLocal Originアイコン

をクリックしてください. 

Local Originダイアログボックスが表示されます.

77._X入力ボックスに0を,Y入力ボックスに66を入力して,原点を0,66に設定します.

この場所は,最初に引いたタップ線の角です.

78._OKボタンをクリックしてダイアログボックスを閉じます.

79._Insertツールバーの四角形アイコン

をクリックします.

80._回路図のLocal Originシンボルの上にカーソルを移動して,シンボルが青い円で強調表示されたら,クリックします.

project editorタブ下部のステータスバーに表示される[ローカル原点]の値は0,0と表示されます.これはあなたの長方形の最初の点です.

81._キーボードで62,16[Enter]入力します.

82._左側のタップラインポリゴンと最初の共振子の間のギャップを拡大します.

83._[挿入]ツールバーのPolygonアイコン

をクリックします.

Add Polygonツールバーが表示されます.長方形と同様に,このポリゴンはデフォルトでTrace metal technologyレイヤーになります.

訳注:メニューから[Insert]-[Draw Polygon]を選ぶか,キーボードでPキーを押してもポリゴンの追加モードになります.

84._描いたばかりのタップ線の長方形の右下隅をクリックします.

これはポリゴンの最初の点です.

85.開始点から3セル上の共振器の端をクリックします.

間違えて間違った点をクリックした場合は,[Del]キーを押して最後に追加した点を削除してから,ポリゴンの入力を続けます.

86._前の点から2セル上の共振器の端をクリックします.

87._タップライン長方形の左上隅をクリックします.

開始点をもう一度クリックして,ポリゴンを完成させます.

ポリゴンを完成させるために,4番目の頂点の後でマウスをダブルクリックすることもできます.テーパーは回路図に描かれています.ポリゴンが完成すると,emによって分析された実際のメタライゼーションを定義する塗りつぶしパターンがディスプレイに表示されます.上の図では,テーパーエッジの階段近似に注目してください. Emはあなたが入力したテーパーをそのまま分析するのでなく,階段近似が分析されます.

89._タップライン長方形とテーパーポリゴンを選択します.

これを行うには,長方形のポリゴンをクリックして選択し,次に[Shift]キーを押しながらテーパーのポリゴンをクリックします.

90._project editorのメインメニューからEdit-Boolean Operations-Unionを選択します.

2つのポリゴンは1つのポリゴンにまとめられます.これは必ずしも解析結果に影響しませんが,ここでは1つのポリゴンにまとめておいたほうが次の手順が楽になります.

91._project editorのメインメニューからView-Full Viewを選択し,テーパーポリゴンをクリックして選択します.

92._project editorのメインメニューからObject-Flip...を選択します.

Flipダイアログボックスが表示されます.

93._Make a copyチェックボックスにチェックします.

94._Pivot PointBox centerラジオボタンをonにしてください.

ボックスの中心をピボットポイントとして反転を実行すると,コピーはもう一方のボックスの壁に配置されます.

95._FlipダイアログボックスのVertical Flipボタン

をクリックし,Closeボタンでダイアログボックスを閉じます.

5番目の共振器と右ボックスの壁の間に正しく配置されます.

96._ローカル原点シンボルを素材の左下隅にドラッグします.

ローカル原点を新しい位置にドラッグすることで,その位置を変更することができます.基板の左下隅は0,0です.

Metal Types

project editorを使用すると,回路で使用する金属の種類をいくつでも定義できます.Planar Metalタイプは,emで使用される導体損失を指定します. DC抵抗率と表皮効果表面インピーダンスの両方がemで正確にモデル化されています.金属の種類と損失の詳細については, 『SONNETユーザーガイド』の「メタライゼーションと誘電体層の損失」を参照してください.

回路にポリゴンを描いた後,平面の金属の種類を変更できます.これを行うには,別の金属タイプを使用する別のテクノロジレイヤを作成するか,ポリゴンを独立またはローカルにします.この例では,すべてのポリゴンがGold_trace金属タイプを使用するTraceテクノロジレイヤに含まれています.ポリゴンを独立型に,1つのポリゴンの平面金属タイプをLossless金属に変更する例を以下に示します.この変更は操作を示すために行うだけで,解析の前に元に戻します.

97._フィルターの任意の共振器をクリックして選択します.

98._project editorのメインメニューからObject-Metal Properties...を選択します.

下に示すように,Planar Polygon Propertiesダイアログボックスがディスプレイに表示されます.

99._Tech Layersドロップリストから<None>を選択します.

これにより,選択したポリゴンがテクノロジレイヤから独立し,ダイアログボックス内のコントロールが有効になります.

100._Planarドロップリストをクリックして,リストからLosslessを選びます. OKボタンをクリックして変更を適用し,ダイアログボックスを閉じます.

下図のように,塗りつぶしパターンが変わります.

このポリゴンの金属は,Lossless Planar Metalと定義され無損失になります. project editorを使用すると,回路で使用する金属の種類をいくつでも定義できます.

101._lossless共振器をダブルクリックします.

Planar Polygon Propertiesダイアログボックスが表示されます.回路内のオブジェクトをダブルクリックすると,適切なプロパティダイアログボックスが開きます.

102._Tech LayersドロップリストからTraceを選択し,OKをクリックしてダイアログボックスを閉じます.

これにより,ポリゴンが再びTraceテクノロジレイヤに割り当てられます.金属フィルパターンが更新され,ポリゴンがGold_trace金属タイプを使用していることを示します.

Metal Fill

金属ポリゴンは,アウトラインとセルの塗りつぶしパターンで表示されます.アウトラインは,入力またはインポートしたものを正確に表しています.セルの塗りつぶしは,emによって分析されるメタライゼーションを表します.したがって,emによって分析された実際のメタライゼーションは,あなたが入力したものとは異なる場合があります.[ctrl]Mキーを使用してセルの塗りつぶしをオンまたはオフにします.次のセクションでは,あなたの回路がグリッドから外れたときに何が起こるかを説明します.

103._ツールバーのSettingsアイコン

をクリックします.

ディスプレイにCircuit Settingダイアログボックスが表示されます.

サイドバーメニューのBoxをクリックし,まだ選択されていない場合はBoxページのBoxタブをクリックします.

105._XCell size4YCell size4に変更します.

106._Circuit SettingsダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じます.

回路は新しいセルサイズを使用して再描画されます.最初のレゾネータの上部を拡大すると,金属ポリゴンがグリッド上で「オン」になっていないことがわかります.この場合,共振器に入力した寸法がセルサイズが小さい場合のようにグリッドに正確に収まらなくなったため,入力ポリゴン(黒のハイライト)と実際のメタライゼーション(クロスハッチング領域)の間にわずかな違いがあります. ). 適切なセルサイズの選択の詳細については, SONNET User's GuideTips for Selecting a Good Cell Sizeを参照してください.

107._同様に,セルサイズを2 x 2ミルに戻してから,フルビューに移動します.

回路が更新され,もう一度金属グリッドが入力ポリゴンと一致するようにグリッド上に配置されます.

Adding Ports

SONNETの回路は,特別なポート番号が使われていない限り,GNDとして扱われる6面の金属製の箱に囲まれているようにモデル化されています.標準的なBox wall port は接地ポートで,一方の端子はボックスの壁と一致するポリゴンの端に,もう一方の端子はグランドに接続されています.そのため,ポートはポリゴンと壁の間の接続を切断し,ポリゴンと壁の間の「無限小」のギャップに挿入されます.ポートの信号(プラス)端子はポリゴンに行き,ポートのアース(負)端子はボックスの壁(アース)に接続されています.Box wall port のモデルは以下のとおりです.

108._[Shift]キーを押しながら,挿入ツールバーのPortアイコン

をクリックします.

[Shift]キーを押しながらアイコンを選ぶと,明示的にモードを終了するまでポートの追加モードになります.これにより,複数のポートを挿入する場合に,毎回ツールバーをクリックする必要がなくなります.

109._ボックスの壁にある左のタップラインの左端をクリックします.

Box wall port があなたの回路に追加されます.ポートタイプは配置に基づいて自動的に決定されます.それらはポートの種類によってシンボルが異なります.詳しくはInsert-Portを参照してください.

110._ボックスの壁にある右のタップラインの右端をクリックします.

もう1つのBox wall port が追加されます.ポートには,作成された順に自動的に番号が付けられています.

これで回路の入力は完了です.次に,分析を設定します.

Analysis Setup

111._ツールバーのSettingsアイコン

をクリックします.

ディスプレイにCircuit Settingダイアログボックスが表示されます.

112._Circuit SettingsダイアログボックスのサイドバーメニューのSweepsをクリックします.

Circuit Settingsダイアログボックスが更新され,Sweepsページが表示されます.デフォルトのABSスイープはすでにスイープセット1に表示されています.ABS(Adaptive Band Synthesis)スイープは,少数の周波数での電磁界解析結果から指定周波数帯域の高分解能分析を抽出するSonnet独自の手法です.Adaptive Band Synthesisの詳細については,SONNET User's GuideAdaptive Band Synthesis(ABS)の章を参照してください.

113._ABSエントリをダブルクリックして掃引を設定します.

114._ABS 4.4 to 5.6 GHzと設定します.

115._Circuit SettingsダイアログボックスのApplyボタンをクリックして,掃引を保存します.

116._Circuit SettingsダイアログボックスのサイドバーメニューのEM Optionsをクリックします.

ダイアログボックスが更新され,Circuit SettingsダイアログボックスのEM Optionsページが表示されます.

117._EM OptionsページでCompute currentsチェックボックスをチェックします.

このオプションは,回路全体の電流密度情報を出力します.これは,電流密度ビューアを使用して表示できます.これについては,この Tutorial の後半で説明します. ABSスイープでは,電流密度データは,完全解析が実行される離散データポイントでのみ計算されます.すべての周波数ポイントで電流密度が必要な場合は,リニア掃引を使用してください.

118._Circuit SettingsダイアログボックスのOKボタンをクリックしてダイアログボックスを閉じ,変更内容を適用します.

回路の設定は完了しましたが,解析を実行する前に project を保存する必要があります.

119.project editorタブのファイルツールバーにある保存アイコン

をクリックします.

project を保存したのは今回が初めてなので,参照ウィンドウが表示されて project の名前を入力できます. 「my_tutorial.son」という名前で project を作業ディレクトリに保存します.

Em, the Analysis Engine

Tutorial の次のセクションでは,入力した回路を電磁界シミュレータエンジンemを使って解析します.以下の説明ではemの背景を説明し,分析エンジンの背後にある理論を説明します.

解析エンジンemは,すべての周波数で完全な精度を維持しながら,任意の3D平面形状に対して電磁界解析を実行します. Emは,考えられるすべての結合メカニズムを考慮に入れたFull wave分析エンジンです.

Emは,モーメント法を使用して回路メタライゼーション上の電流分布を解くことにより,マイクロストリップ,ストリップライン,コプレーナ導波路,またはその他の3D平面回路の電磁解析を実行します.

Subsectioning the Circuit

解析は,回路メタライゼーションを小さな長方形のサブセクションに分割することから始まります.以下に示す実際のサブセクションでは,小さなサブセクションは必要な場合にのみ使用されます.

それ以外の場合は,分析時間がサブセクションの数に直接関係するため,より大きなサブセクションが使用されます.これらのサブセクションは,geometry ファイルで指定されたセルに基づいています.

Emは,回路内のサブセクションの各可能なペア間の「結合」を効果的に計算します.

120._project editorのメインメニューからCircuit-Estimate Memory...を選択します.

Estimate Memoryウィンドウが表示されます.Num.Cellsが大きい場合は多くのセルをサブセクションにまとめるため少し時間がかかるかもしれません.まとまったサブセクションの数をもとに解析のために必要なメモリを見積もります.このコマンドは,分析を実行するために利用可能なコンピュータリソースがあるかどうかを判断するのに役立ちます.

121._Estimate MemoryウィンドウのView Subsectionsボタンをクリックします.

Subsectionsタブにサブセクションが表示されます.ビアのサブセクションは層0には表示されませんが,GND層を見るとそれらを見ることができます.

122._タブの隅にある赤い印をクリックして,サブセクションビューアタブを閉じます.

123.project editorタブで,ボタン

をクリックしてください.

セッションウィンドウにJob Queuesタブが表示されます.複数の分析サーバーを使用している場合は,どのサーバーをこのキューに割り当てるかを尋ねられます.

分析は,Job Queuesタブで設定されます.Job Queuesタブには,分析を監視したり,分析を実行するためのキューを管理したりするためのインターフェイスがあります.分析制御設定は project ファイルの一部として保存されます.

この my_tutorial.sonは,分析がまだ実行されていないことを示すアイコン![]ボタンをクリックするまで分析は実行されません.

124._Queue type drop listManual StartからAuto Startに切り替えます.

これでジョブがキューに入るとすぐに解析が始まるようになります. これ以後Queue type drop listManual Startを選択するまで,それ以降に開かれるすべてのジョブキューはAuto Startに設定されます. しかしAuto Startへの変更は現在のキューには影響しないので,最初だけはManual Startする必要があります.

125._ジョブキューの上にある

Runボタンをクリックして解析を開始します.

進行状況バーがJob Queuesタブに表示されます.ステータスデータは下のウィンドウに出力されますが,この例題ではあっという間に終わってしまうでしょう.ジョブが完了すると,進行状況バーの下にEm simulation completedというメッセージが表示され,アイコンが

に変わります.

このABSスイープではたった4つの周波数における電磁界解析結果から241周波数分解能の結果を得たことに注意してください.

Response Viewer - あなたのデータをプロットする

Response Viewerを使用して,em分析の結果を直交座標グラフまたはスミスチャートとして表示します. S,Y,Zパラメータだけでなく他の多くのパラメータも表示できます.複数の project からの複数の曲線を同時に表示することもできます.パラメータスイープでは横軸をパラメータにしたり,最適化の場合は試行回数を横軸に表示することもできます.この Tutorial では,Response Viewerの最も基本的な機能についてのみ説明します.

126._Job QueuesタブのメインメニューからLaunch-Graph Response-New Graphを選択します.

セッションウィンドウに,デフォルトのS11の測定値が表示されたGraphタブが表示されます.また,起動ツールバーのGraphボタン

をクリックしてGraphタブを開くこともできます.

DB[S11]が曲線リストに表示され,プロット内のデータを識別します. project 名は曲線を識別するためにも使用されます.これは,複数の project からデータをプロットしている場合に役立ちます.プロット内の選択した点は赤い四角で強調表示されます.そのポイントのデータは,タブの下部にあるステータスバーに表示されます.プロット内のマーカーの付いた点は,電磁界解析が行われた離散周波数ポイントを表します.ABSから生成されたデータにはマーカーが表示されません.

セッションマネージャも更新され,開いているすべてのタブがセッションマネージャツリーに表示されます.Graphタブは現在セッションウィンドウに表示されているタブなので,そのエントリはセッションマネージャで強調表示されます.別のエントリをクリックすると,セッションウィンドウにそのタブが表示されます.

Graphタブの詳細については,メインメニューからHelp-Help on this tabを選択してください.

127._ツールバーのCurbesアイコン

をクリックします.

Manage Curvesダイアログボックスがディスプレイに表示されます.このダイアログボックスでは,曲線を追加および編集したり,曲線グループを管理したりできます.次に,DB[S21]を追加してみます.

128._Manage CurvesダイアログボックスのAddボタンをクリックします.

もう1つのDB[S11]がリストに追加されます.新しい曲線がリストで選択されている(灰色でハイライトされている)ので,MeasurementsセクションまたはPropertiesセクションで行われた変更はすべてこの曲線に適用されます. Sパラメータをもう1つ追加したいので,Measurementsに変更を加える必要はありません.この色には新しい色が自動的に割り当てられていますが,Propertiesセクションで変更することができます.

129._PropertiesセクションのTo Portフィールドをクリックして編集を有効にします.

エントリが強調表示され,左側に小さな下向きの矢印が表示されます.

130.下矢印をクリックして,ドロップリストから2を選択します.

プロパティはプロットに追加されたDB[S21]曲線を定義します.

131._Manage Curvesダイアログボックスで,Deleteボタンをクリックします.

追加したばかりのDB[S21]曲線が削除されます.プロットが更新され,DB[S11]曲線のみが表示されます.これでDB[S11]曲線がCurvesセクションで選択されているはずです.

132._MeasurementsセクションのTransmission Linesの下のLine Z0をクリックします.

CurvesエントリがMAG[PZ1]に更新されます.[プロパティ]のデフォルト設定はすべて正しいので,それ以上の変更は必要ありません.プロットも更新されます.

![]ダイアログボックスで測定値にカーソルを合わせると,簡単な説明が表示されます. Windowsでは,ダイアログボックスのタイトルバーの右の?をクリックして,次にMeasurementsエントリをクリックして詳細な説明を表示します.

訳注:Measurementsに用意されているパラメータの意味はHelpボタンを押して詳細な説明を理解してから使用してください.特に "いんぴーだんす","容量","いんだくたんす"など定義やその前提となる仮定によって全く違う値になることを忘れないでください.

Manage CurvesダイアログボックスのCloseボタンをクリックして閉じます.

134._Response ViewerのメインメニューからView-Smith Chart...を選択します.

セッションウィンドウに新しいタブが表示され,[S11]のスミスチャートが表示されます.

135._タブの隅にある赤い印をクリックしてSmithタブを閉じます.

Current Density Viewer

電流密度ビューアは,emで解析された回路の結果を表示するために使用される視覚化ツールです. Emは,解析結果の電流密度情報を project ファイルに保存し,電流密度ビューアに入力できるようにします.

電流密度データを作成するには, 解析前にCircuit SettingsダイアログボックスのEM OptionsページでCompute currentsチェックボックスをチェックしておく必要があります.

136._ツールバーのCurrentボタン

をクリックします

電流密度タブが開き, 最初の4.4 GHzの周波数において,ポート1に1ボルト,50Ωソース,ポート2に50Ω負荷を接続した場合の電流密度が表示されます.これはデフォルト設定で,電圧と負荷の任意の組み合わせや,スケールを変更できます.

137._任意の点をクリックすると電流密度値(アンペア/メートル)が,位置の座標と共にウィンドウ下部のステータスバーに表示されます.

138._ツールバーのUpボタン

をクリックします.

Upボタン

をクリックする都度,次の周波数での電流密度が表示されます.

139._Frequency Dropリストをクリックし,5.6を選択します.

ドロップリストを使用すると,任意の分析頻度に直接移動できます.電流密度データが計算されるABS分析の周波数ポイントはABSアルゴリズムによって自動的に決定され,通常は不均一です.

140._電流密度ビューアのツールバーの3D Current Viewボタン

をクリックします

3Dビューを表示する新しいタブが開きます.マウスをクリックしてドラッグすると,ビューを3次元で回転できます.

訳注:シミュレーションの結果を可視化すると多くの人に印象を残すことができますが,スケールや表示条件次第で見る人に全く異なる印象を与えることもできます.また,意義のある判断をするには電磁気学や回路理論への非常に高度な理解が必要なことを忘れないでください.

141._メインメニューからFile-Exit SONNETを選択します.

ソフトウェアは閉じられます.次にソフトウェアを開くと,exitコマンドを選択したときに開いていたタブが表示されます.これでSONNETの Tutorial は終了です.

Copyright © 2019 by Sonnet Software, Inc. All Rights Reserved.